Subject: Re: CEO REF 07784

From: Nick Moloney <[email-masked]>
Date: Mon, 14 Nov 2022 09:00:36 +0000

Good morning Jimmy & Margaret,

I thought this extract may be of use to you both and for the day that it is, I have also attached “Apologies Guidelines 2nd Edition.pdf" so that lessons may be learned.

____________________

tellus?ver=v46549f6b.js
____________________

function FormDetails() {
this.Name;

this.Email;
this.ConfirmEmail;
this.Address;
this.Phone;
this.Message;
this.Permission;

this.Captcha;

}
$(document).ready(function () {

$('.datepicker').datepicker({
'format': 'dd/mm/yyyy',
autoclose: true

});
$(".required").change(function () {
if ($(this).val() != "") {

$(this).parent().find('.error').hide(1000, function () {
$(this).parent().find('.error').remove();

});
$("#submitContact").click(function (e) {
e.preventDefault();

****************************************************
****************************************************

if (IsContactFormValid()) {

var contactDetails = new FormDetails();
contactDetails.Type = $("input[name=type]:checked").val();
contactDetails.Name = $("#txtName").val();
contactDetails.Address = $("#txtAddress").val().trim();
contactDetails.Phone = $("#txtPhone").val().trim();
contactDetails.Email = $("#txtEmail").val().trim();
contactDetails.ConfirmEmail = $("#txtConfirmEmail").val().trim();
contactDetails.Service = $("#txtService").val().trim();
contactDetails.Location = $("#txtLocation").val().trim();
contactDetails.IncidentDate = $("#incidentDate").val();
contactDetails.Message = $("#txtMessage").val();
contactDetails.Permission = $("#cbkPermission").is(":checked");
contactDetails.Under18 = $("#under18").is(":checked");
contactDetails.NameGuardian = $("#txtNameGuardian").val();
contactDetails.AddressGuardian = $("#txtAddressGuardian").val();

contactDetails.Captcha = $("#txtCaptcha").val();
contactDetails.RecaptchaValue = $("#g-recaptcha-response").val();
$.ajax({

type: "POST",
url: "/Webservices/Contact.asmx/TellUs",
contentType: "application/json; charset=utf-8",
data: JSON.stringify({ 'json': contactDetails }),
async: false,
dataType: "json",
success: function (data, status) {

var responseObject = JSON.parse(data.d);

if (responseObject.IsSuccess) {
$("#contactUsForm").hide(0, function () {

$("#submitSuccess").show();
$('html, body').animate({

} });
scrollTop: $("#submitSuccess").offset().top - 350

}, 1000); })
}

*****************************************************
*****************************************************

else {
if (responseObject.Message == "Invalid Captcha Code entered") {
$("#recaptcha").after("<p class='error'>Invalid Captcha

grecaptcha.reset();
}

}
},
error: function (data, status) {

alert("Error Send Message!")
}

});
} else {
//Show Error

} });
});
function checkenterPressed(e) {

if (e.keyCode == 13) {
e.preventDefault();
$("#submitContact").trigger("click");
return false;

} }
function isValidEmailAddress(email) {
var re = /^[a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6}$/;
return re.test(email);

}
function IsContactFormValid() {
var result = true;
$(".error").remove();
$("input.required, textarea.required").each(function (i, ele) {

if ($(ele).val() == null || $(ele).val().trim() == "") {
result = false;

$(ele).after("<p class='error'>Required Field</p>");
}

});
if ($("#txtEmail").val().toLowerCase().trim() !=
$("#txtConfirmEmail").val().toLowerCase().trim()) {

result = false;

$("#txtConfirmEmail").after("<p class='error'>Emails must match</p>")
} else if ($("#txtEmail").val().trim() != "") {

if (!isValidEmailAddress($("#txtEmail").val())) {
result = false;

$("#txtEmail").after("<p class='error'>Invalid Email Address</p>")
}

}
if ($("#g-recaptcha-response").val() == "") { result = false;
$("#recaptcha").after("<p class='error'>Recaptcha is invalid</p>")
}

entered</p>");

return result;
}

function RefreshCaptcha() {
var img = document.getElementById("imgCaptcha");
img.src = "/CaptchaHandler.ashx?query=" + Math.random();

}

____________________
____________________

Kind regards,

Nick.

> On 8 Nov 2022, at 09:00, Nick Moloney <[email-masked]> wrote:
> 
> Good morning Jimmy,
> 
> Thank you for the email but it just doesn’t make sense.
> 
> For example:
> 
> - Due to a potential technical issue
> 
> - Whilst receiving an automated response, was not actually delivered
> 
> - The exchange server logs only go back 30 days
> 
> - Looked into this issue thoroughly they could not locate the email in question
> 
> - We welcome and are grateful for your feedback
> 
> - Significant work has been undertaken to strengthen HSE email
> 
> But I get it.
> 
> Jimmy, I have no ill feelings for you and I wish you and your family a wonderful warm Christmas,
> 
> My kind regards,
> 
> 
> Nick.
> 
> 
> 
> 
>> On 7 Nov 2022, at 15:15, CeoToComplaints <[email-masked]> wrote:
>> 
>> Dear Mr. Moloney,
>> 
>> From our follow up with the HSE IT department, they have advised that, due to a potential technical issue, your feedback, whilst receiving an automated response, was not actually delivered internally to the Your Service Your Say email inbox on the 26th January 2021. The HSE IT Department also advised that unfortunately the exchange server logs only go back 30 days and although their technical team have looked into this issue thoroughly they could not locate the email in question.
>> 
>> We would like to sincerely apologise to you for this and we welcome and are grateful for your feedback. Following the HSE cyber-attack in May 2021 significant work has been undertaken to strengthen HSE email to ensure that it is robust and secure and this will hopefully minimise such instances happening into the future.
>> 
>> I trust the above information is of assistance to you.
>> 
>> Kind regards,
>> 
>> Jimmy
>> 
>> Jimmy Burke
>> 
>> Senior Executive Officer I Oifigeach Feidhmiúcháin Sinsearach Oifig Náisiúnta FnaSS – Do Sheirbhís, Do Thuairim, Teach Darach, Ascail na Teile, Páirc na Mílaoise, An Nás, Co. Chill Dara, W91 KDC2 HSE National Your Service Your Say Office, Oak House, Limetree Avenue, Millennium Park, Naas, Co Kildare, W91 KDC2
>> 045 880429  |  [email-masked]
>> 
>> -----Original Message-----
>> From: Nick Moloney <[email-masked]>
>> Sent: Monday 24 October 2022 09:01
>> To: CeoToComplaints <[email-masked]>
>> Subject: Re: CEO REF 07784
>> 
>> Good morning Margaret,
>> 
>> I was wondering how the HSE IT Services got on, Having worked in the IT sector, I understand about data recovery RPO’s and RTO’s etc.
>> 
>> The restoration of my complaint has nothing to do with what I have been put through after the deletion of my complaint by the HSE.
>> 
>> I attach "The Aftermath of the Deletion of my Complaint by the HSE.pdf” .
>> 
>> Kind regards,
>> 
>> Nick.
>> 
>> 
>> 
>> Need information and advice on COVID-19? Go to www.hse.ie/coronavirus<https://www.hse.ie/coronavirus>
>> 
>> ________________________________
>> "Tá an fhaisnéis sa ríomhphost seo (ceangaltáin san áireamh) faoi rún. Baineann sé leis an té ar seoladh chuige amháin agus tá sé ar intinn go bhfaighfidh siadsan amháin é agus gurb iadsan amháin a dhéanfaidh breithniú air. Más rud é nach tusa an duine ar leis é, tá cosc iomlán ar aon fhaisnéis atá ann, a úsáid, a chraobhscaoileadh, a scaipeadh, a nochtadh, a fhoilsiú, ná a chóipeáil . Seains gurb iad tuairimí pearsanta an údar atá san ríomhphost agus nach tuairimí FSS iad.
>> 
>> Má fuair tú an ríomhphost seo trí dhearmad, bheadh muid buíoch dá gcuirfeá in iúil don Deasc Seirbhísí ECT ar an nguthán ag +353 818 300300<tel:%2B353%20818%20300300> nó ar an ríomhphost chuig [email-masked]<mailto:[email-masked]> agus ansin glan an ríomhphost seo ded' chóras."
>> 
>> 
>> 
>> "Information in this email (including attachments) is confidential. It is intended for receipt and consideration only by the intended recipient. If you are not an addressee or intended recipient, any use, dissemination, distribution, disclosure, publication or copying of information contained in this email is strictly prohibited. Opinions expressed in this email may be personal to the author and are not necessarily the opinions of the HSE.
>> 
>> If this email has been received by you in error we would be grateful if you could immediately notify the ICT Service Desk by telephone at +353 818 300300<tel:%2B353%20818%20300300> or by email to [email-masked]<mailto:[email-masked]> and thereafter delete this e-mail from your system"
>> 
>> ________________________________
>> 
>> 
>

---

From: Nick Moloney <[email-masked]>
Date: Tue, 8 Nov 2022 09:00:01 +0000

Good morning Jimmy,

For example:

But I get it.

My kind regards,

Nick.

---

From: CeoToComplaints <[email-masked]>
Date: Mon, 7 Nov 2022 15:15:54 +0000

Dear Mr. Moloney,

Kind regards,

Jimmy

Jimmy Burke

-----Original Message-----
From: Nick Moloney <[email-masked]>
Sent: Monday 24 October 2022 09:01
To: CeoToComplaints <[email-masked]>
Subject: Re: CEO REF 07784

Good morning Margaret,

Kind regards,

Nick.

---

From: CeoToComplaints <[email-masked]>
Date: Wed, 26 Oct 2022 12:54:58 +0000

Dear Mr Moloney,

I wish to acknowledge your further email received on October 24th 2022 and thank you for same

In accordance with the HSE's Your Service Your Say, the Management of Service User Feedback for Comments, Compliments and Complaints policy, your correspondence has been forwarded to the appropriate Consumer Affairs office who will ensure that your concerns are examined by University Hospital Limerick.

Kind regards,
Margaret

Margaret Mulhall
Staff Officer I Oifigeach Foirne

Oifig Náisiúnta FnaSS - Do Sheirbhís, Do Thuairim, Teach Darach, Ascail na Teile, Páirc na Mílaoise, An Nás, Co. Chill Dara, W91 KDC2
HSE National Your Service Your Say Office, Oak House, Limetree Avenue, Millennium Park, Naas, Co Kildare, W91 KDC2
045 880429  |  [email-masked]

===========
IMPORTANT
===========
Information in this e-mail (including attachments) may be confidential. It is intended for receipt and consideration only by the intended recipient. If you are not the intended recipient, any use, dissemination, disclosure, publication or copying of information contained in this e-mail (including attachments) is strictly prohibited. Opinions expressed in this e-mail may be personal to the author and are not necessarily the opinions of the Health Service Executive. If this e-mail has been received by you in error, please notify the sender and then delete the email from your system.

-----Original Message-----
From: Nick Moloney <[email-masked]>
Sent: 24 October 2022 09:01
To: CeoToComplaints <[email-masked]>
Subject: Re: CEO REF 07784

CAUTION: This email originated from outside of the organisation. Do not click links or open attachments unless you recognise the sender and know the content is safe.

---

From: CeoToComplaints <[email-masked]>
Date: Mon, 24 Oct 2022 14:47:22 +0000

Dear Mr. Moloney,

I wish to acknowledge your further email received on October 19th 2022 and thank you for same.

I can confirm that in accordance with the HSE's Your Service Your Say, the Management of Service User Feedback for Comments, Compliments and Complaints policy, your complaint, which you submitted to this office on September 20th was forwarded to the Consumer Affairs office at University Hospital Limerick. The Consumer Affairs office at University Hospital Limerick will ensure that your concerns are examined and will respond to you directly.

Kind regards,
Margaret

Margaret Mulhall

===========
IMPORTANT
===========

---

From: Nick Moloney <[email-masked]>
Date: Mon, 24 Oct 2022 09:00:53 +0100

Good morning Margaret,

Kind regards,

Nick.

> On 19 Oct 2022, at 16:25, Nick Moloney <[email-masked]> wrote:
> 
> Good afternoon Margaret,
> 
> Thank you for the information below, but this has not answered my email dated 6 October 2022 and hence I sent a further email dated 12 October 2022 as I did not receive any reply from Jimmy Burke.
> 
> With that said, I await the further information that you have requested from the HSE IT Services with the knowledge of the contents of the YSYS Form dated 26 January 2021.
> 
> Kind regards,
> 
> Nick.
> 
> 
> 
> 
>> On 19 Oct 2022, at 12:34, CeoToComplaints <[email-masked]> wrote:
>> 
>> Dear Mr. Moloney,
>> 
>> I wish to acknowledge your further email received on October 12th 2022 and thank you for same.
>> 
>> I can advise that we have contacted HSE Information Technology (IT) Services for an update in relation to the request to retrieve feedback submitted by you to Your Service Your Say on the 26/1/2021. We have been advised by HSE IT that this request has been assigned to the appropriate department and it is in the process of investigation.
>> 
>> I trust the above information is of assistance to you and we will contact you as soon as further information is provided to us by HSE IT Services in relation to this request.
>> 
>> Kind regards,
>> Margaret
>> 
>> Margaret Mulhall
>> Sent: 12 October 2022 16:07
>> Subject: CEO REF 07784

---

From: Nick Moloney <[email-masked]>
Date: Wed, 19 Oct 2022 16:25:21 +0100

Good afternoon Margaret,

Kind regards,

Nick.

---

From: CeoToComplaints <[email-masked]>
Date: Wed, 19 Oct 2022 11:34:42 +0000

Dear Mr. Moloney,

Kind regards,
Margaret

Margaret Mulhall

===========
IMPORTANT
===========

---

From: Nick Moloney <[email-masked]>
Date: Wed, 12 Oct 2022 16:07:15 +0100

Good afternoon Jimmy,

Any news for me. I await to hear from you.

Kind regards,

Nick.